cisco_switch_설정

Cisco Switch 설정

시스코 펌웨어 다운로드 : https://cdn.technet24.ir/Downloads/Cisco/IOS/

패스워드 분실 또는 공장 초기화를 위한 Rommon mode 진입방법
전면 mode 버튼 누른채로 전원 입력

그러면 rommon mode 로 진입이 된다.

가장 먼저 해야할 일은 BAUD RATE 설정이다.

switch: set BAUD 115200

// 변경하는 순간 터미널이 동작하지 않을수 있다. 이런경우 터미널 속도를 115200으로 변경 후 재 접속한다.

switch: set
BAUD=115200
...

스위치 초기화
초기화 방법은 VLAN 정보가 저장된 vlan.dat 파일을 delete vlan.dat 명령어를 사용하여 삭제한다.
또 erase start 명령어를 사용하여 설정파일도 지운후 reload 명령어를 사용하여 재부팅한다.
reload 명령어 사용시 설정사항 저장여부를 물으면 no 라고한다

#del vlan.dat
#erase start
#reload
no
switch#>show version // 버전확인
switch#>show inventory // 모델확인
switch#>show interface vlan // 아이피 주소 설정 표시
switch#>show running-config //현재 활성화된 설정 표시

R1# show flash                                         -> Flash 정보 확인
R1# show ip route                                     -> 라우팅 테이블
R1# show ip interface brief                       -> 인터페이스 정보
R1# show interface [Interface Name]        -> 인터페이스 상황과 통계치
R1# show controllers [Interface Name]      -> 인터페이스에 연결된 케이블이 확인 및 점검
R1# show cdp neighbor                            -> 이웃 장비 확인
R1# show cdp neighbor detail                    -> 인접한 장비의 IP 및 호스트네임 기타 등등 자세히
R1# show running-config                          -> Running-Config (RAM) 확인
R1# show startup-config                           -> Startup-Config (NVRAM) 확인
R1# copy running-config startup-config      -> RAM에서 NVRAM으로 설정 사항 저장
R1# erase startup-config                          -> NVRAM 삭제
Switch# configure terminal
Switch(config)# interface vlan 1
Switch(config-if)# ip address 192.168.1.2 255.255.255.0
Switch(config-if)# no shutdown
Switch(config-if)# exit
Switch(config)# ip default-gateway 192.168.1.1

DHCP 이용하여 설정
1. 전역 설정 모드에서 interface vlan 1 명령어로 VLAN 1 설정 모드로 진입한다.
2. ip address dhcp 명령어로 IP 주소와 서브넷 마스크 설정한다.
3. no shutdown 명령어로 VLAN 1 가상 인터페이스 활성화한다.
4번이었던 디폴트 게이트웨이 설정을 하지 않는다는 것이 차이점이 있다.

한 가지 알아야 할 점은 dhcp로 IP 주소를 설정할 경우 show running-config 명령어로는 IP 주소를 볼 수 없다.
이때는 show dhcp lease 명령어나 show interface vlan 1 명령어를 통해 IP 주소를 확인할 수 있다.

# conf t
(config) # service timestaps debug datetime localtime  // debug 타임스탬프 변경
(config) # service timestaps log deatetime localtime  // log 타임스탬프 변경
# sh clock  // 장비 현재 시간 확인
# clock set 13:13:13 april 20 2020  // 장비 시간 설정
# clock timezone kst 9  // 타임존 설정 (한국시간)

# conf t
(config) # ntp server time.bora.net  // NTP 서버 지정 (boranet)
# sh ntp status  // NTP 서버 동기화 상태 확인
  • 로깅 싱크설정

스위치에서 설정작업을 하다보면 명령어 입력도중 시스템 관련메시지가 자동으로 표시되므로
명령어를 제대로 입력하기 위해 싱크작업을 한다

gmate(config)# line 0 16
gmate(config-line)# logg sync
  • 콘솔접속 유지하기
gmate(config)#line console 0
gmate(config-line)# exec-timeout 0
  • 패스워드 설정
gmate(config)# enable secret switch

해당명령어는 관리자 패스워드를 switch 로 설정하겠다는 뜻이다

  • 라인상황 확인하기
gmate#show line

라인상황을 확인후 VTY 설정을 한다

gmate(config)#line vty 0 15
gmate(config-line)# password switch

이러면 원격접속 라인 0~ 15까지 라인의 패스워드가 switch 로 설정된다

  • 컨피그 확인 방법
gmate#show runnign-config
  • vty 패스워드는 암호화 되지 않았기에 암호화를 한다
gmate(config)#service password-encryption
  • 배너달기
gmate(config)#banner motd *
Authonized access only!!
*

시작전후 *을쓴다

  • 한글배너 입력하기
gmate(config)# default-value exec-character-bits 8
gmate(config)# banner motd *
비인가자의 접속을 엄금합니다!!
*
gmate(config)#
  • 인터페이스 설명달기
gmate(config)# interface f 1/0/1
gmate(config)# description gmate1
gmate(config)# interface f 1/0/2
gmate(config)# description gmate2
  • 기본설정파일 셋팅
enable
config terminal
no ip domain-lookup
enable secret $gm@te2oo8

alias exec c config terminal
alias exec r show running-config
alias exec i show ip route
alias exec b show ip interface breif

line consol 0
logging synch
exec-timeout 0
lin vty 0 5
pass $gm@te2oo8
exit
hostname
cisco(config)#
cisco(config)#ip domain-lookup
cisco(config)#ip name-server 210.20.64.21
  • 도메인 검색 끄기
cisco(config)# no ip domain-lookup
  • stp
Switch# show spanning-tree
Switch# show spanning-tree vlan [num]
Switch# show spanning-tree vlan [num] detail
  • 포트상태
Switch# show interface status
  • link aggregation
Switch(config)# int port-channel 1
Switch(config-if)# int range gi 1/0/5-6
// chnnel-group 1 mode on
channel-group 1 mode active

Switch(config-if)# channel-proto lacp
Switch(config-if)# exit

Switch(config)# int port-channel 1
Switch(config-if)# switchport mode access
Switch(config-if)# switchport access vlan 10

확인
Switch# show lacp neighbor
로그인하면 댓글을 남길 수 있습니다.
  • cisco_switch_설정.txt
  • 마지막으로 수정됨: 2023/04/12 04:46
  • 저자 koov